Animationsintervall eines Schiebereglers

meinolf.mueller shared this question 2 years ago
Answered

Hallo, ich habe eine Animation (im Anhang), in der ich in der Animationsgeschwindigkeit einstellen kann, was ich will, die Animation benötigt immer mehrere Sekunden von Step zu Step. Derzeit steht das Intervall auf 0,05. Wie kann ich dafür sorgen, dass die Animation so abläuft, wie ich es mir wünsche?

Comments (5)

photo
1

Salut Meinolf!

Deine Frage ist ein wenig "ungewöhnlich", denn einerseits klingt es so, als ob Du die Animationsgeschwindigkeit auf 0.05 gesetzt hast und andererseits fragst Du, wie Du diese denn ändern kannst.

Du kannst bei Deinem Schieberegler "u" z. B. mit Rechtsklick unter "Eigenschaften" -> "Schieberegler" die Geschwindigkeit verändern und Dir dann anschauen, ob es so animiert wird, wie Du es möchtest.

Kann natürlich auch sein, dass ich da was missverstanden habe ....

Gruß

mire2

813dc0cd39412e2d0ef1cfa8d1716be6

photo
1

Hallo, danke,

ich weiß, wo man die Geschwindigkeit einstellt. Nur, meine Frage war, warum diese Geschwindigkeit bei Ausführung des App mehrere Sekunden von Intervall zu Intervall benötigt, obwohl ja nur 0,05 eingestellt war.

Viele Grüße

Meinolf

photo
1

Aha, hab ich es doch falsch verstanden.


Nun, die Zahl 1 bedeutet so als grobe Richtschnur, dass die komplette Animation ca. 10 Sekunden für einen kompletten Durchlauf benötigt und je größer der Zahlenwert, desto schneller läuft die Animation.

Ein Zahlenwert von 0.05 bedeutet also, dass die Animation 20 mal langsamer durchlaufen wird, also ca. 200 Sekunden bzw. ca. 3 Minuten dauert und bei ca. 30 Animationsschritten (Schrittweite 0.1 von -1.5 bis 1.5) bist Du dann bei grob 6 Sekunden je Schritt.

Das hängt natürlich alles von der Komplexität der Konstruktion ab, aber so als grobe Richtschnur taugt das hier vielleicht schon.


Gruß

mire2

photo
1

Hallo Mire,

danke, also habe ich nur komplett verkehrt rum gedacht. Dachte, jekleiner die Zahl, je schneller die Animation.

Viele Grüße

Meinolf

photo
1

Hallo Mire,

jetzt wollte ich nicht einen neuen Thread eröffnen. Ich habe die App jetzt auf GEOGEBRA.org hochgeladen ( https://www.geogebra.org/m/nqysfujs ). Wenn ich sie dann dort starte läuft aber das angegebene Animationsintervall von 0,1 nicht in diesen Abständen ab. Warum eigentlich? (Die Originaldatei hier noch mal im Anhang).

Gruß

Meinolf

photo
© 2020 International GeoGebra Institute