3D window not working properly

mtibor shared this question 9 years ago
Answered

Looks like I am experiencing serious problems with GeoGebra's 3D window on my new laptop, which makes 3D practically unuseable. Any help will be appreciated. A brief description:


* Placing points directly in the 3D window does not work - if the mouse cursor moves around the 3D window, the point does not move freely but is bound to the x axis (instead of a cross moving around the xy plane, there is just a "ball" moving along x axis)


* If a polygon is placed in the 2D window, that polygon renders correctly in 3D window and, consequently, the point tool seems to work correctly (a cross moving around xy plane). However, the polygon is intouchable - it is impossible to extrude it into a pyramid or prism.


* If the projection is changed to anaglyph and the whole 3D view is rotated, zoomed or moved, only the red component rotates/moves/zooms. The cyan component stays fixed at the exact position where the projection was switched to analyph.


The above problems are the same regardless of a JOGL or classic Windows installation.


There is surely more that does not work; however, elementary 3D tools are so unreliable on this particular computer that it is hard to get any further.


System:

A HP Laptop with Windows 7, 64 bit. (I have 2 other computers with this system and they work just fine with GeoGebra 5.)

Java 7 (update 9). I tried both 32 and 64 bit versions. I also tried to go back to Java 6 (37) to no avail.

CPU: Intel QuadCore i7-3720QM CPU @ 2.60GHz

8 GB RAM

Video: NVIDIA GeForce GT 650M (2GB)

GeoGebra Log copied below.


    GeoGebra 4.9.67.0-JOGL2 (23 October 2012)

    Java: 1.7.0_09

    Codebase: http://jars.geogebra.org/we...

    OS: Windows 7

    Architecture: x86

    Heap: 494MB

    CAS: MPReduce .016


    GeoGebraLogger log:

    23:52:40.065 INFO: geogebra.i.a.a[-1]: GeoGebra 4.9.67.0 23 October 2012 Java 1.7.0_09-32bit

    23:52:40.065 DEBUG: geogebra.i.a.<init>[-1]: isApplet=false runningFromJar=true appletImpl=null

    23:52:40.065 DEBUG: geogebra.i.a.au[-1]: Setting up logging

    23:52:40.068 DEBUG: geogebra.i.a.au[-1]: Logging is redirected to C:\Users\Laptop\AppData\Local\Temp\GeoGebraLog_xdouyjabmi.txt

    DEBUG: geogebra.common.i.p.B[-1]: Number of registered views = 1

    * class geogebra3D.b.c

    DEBUG: geogebra3D.euclidian3D.S.ag[-1]: create gl renderer

    DEBUG: geogebra3D.euclidian3D.opengl.Renderer.<init>[-1]: create 3D component

    DEBUG: geogebra3D.euclidian3D.opengl.Renderer.<init>[-1]: add gl event listener

    DEBUG: geogebra3D.euclidian3D.opengl.Renderer.<init>[-1]: create animator

    DEBUG: geogebra3D.euclidian3D.opengl.Renderer.<init>[-1]: start animator

    DEBUG: geogebra.common.i.p.B[-1]: Number of registered views = 2

    * class geogebra3D.b.c

    * class geogebra3D.euclidian3D.S

    DEBUG: geogebra.common.b.c.a.a[-1]: Trying to enable SingularWS connection

    DEBUG: geogebra.common.b.c.a.a[-1]: SingularWS supports library grobcovC1

    INFO: geogebra.common.j.a.s[-1]: SingularWS is available at http://singularws.idm.jku.at/

    DEBUG: geogebra.common.i.p.B[-1]: Number of registered views = 3

    * class geogebra3D.b.c

    * class geogebra3D.euclidian3D.S

    * class geogebra3D.d.c.a.b

    WARN: geogebra.i.a.s[-1]: Option versionCheckAllow not recognized :

    INFO: geogebra.i.x.a[-1]: No system preferences

    DEBUG: geogebra.common.i.p.B[-1]: Number of registered views = 4

    * class geogebra3D.b.c

    * class geogebra3D.euclidian3D.S

    * class geogebra3D.d.c.a.b

    * class geogebra.common.plugin.b

    ERROR: geogebra.l.k.b[-1]: Image /gui/menubar/images/en.png not found

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseCFactor

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseCross

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseCSolutions

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseCSolve

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseDot

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseGroebner

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseNIntegral

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseNSolve

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseNSolutions

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseNumeric

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseMixedNumber

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseRationalize

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseSolutions

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseSolve

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseSubstitute

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseToExponential

    DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseToPoint

    DEBUG: geogebra.gui.i.O.b[-1]: update menu

    DEBUG: geogebra.plugin.jython.b.c[-1]: Initialising Python interpreter...

    DEBUG: geogebra.plugin.jython.b.c[-1]: Done Initialising Python interpreter.

    DEBUG: geogebra.gui.a.a$a.a[-1]: Checking version

    DEBUG: geogebra.gui.a.a$a.a[-1]: version check needed: no check was done yet

    DEBUG: geogebra.gui.a.a$a.a[-1]: current=4009067000 newest=4000041000

    DEBUG: geogebra.b.b.g.<init>[-1]: possible missing release()

    DEBUG: geogebra.gui.i.a.menuSelected[-1]: Menu opening: class geogebra.gui.i.Y

    DEBUG: geogebra.gui.i.a.menuSelected[-1]: creating menu items

    DEBUG: geogebra.gui.i.Y.a[-1]: using flag: us.png

    DEBUG: geogebra.common.l.n.a[-1]: country from GeoIP: US

    DEBUG: geogebra.gui.i.a.menuSelected[-1]: Menu opening: class geogebra.gui.i.ag

    DEBUG: geogebra.gui.i.a.menuSelected[-1]: creating menu items

    DEBUG: geogebra.gui.i.a.menuSelected[-1]: Menu opening: class geogebra.gui.i.Y

    DEBUG: geogebra.gui.i.a.menuSelected[-1]: Menu opening: class geogebra.gui.i.ak

    DEBUG: geogebra.gui.i.a.menuSelected[-1]: creating menu items

    DEBUG: geogebra3D.d.b.b[-1]: TODO: how to attach 3D view?

    DEBUG: geogebra.gui.k.f.a[-1]: invalid toolbar string: null

    DEBUG: geogebra3D.euclidian3D.opengl.Renderer.init[-1]: openGL version : 3.0.0 - Build 8.15.10.2626, vbo supported : true

    DEBUG: geogebra3D.euclidian3D.opengl.Renderer.init[-1]: openGL version : 3.0.0 - Build 8.15.10.2626, vbo supported : true

    DEBUG: geogebra.gui.i.a.menuSelected[-1]: Menu opening: class geogebra.gui.i.R

    DEBUG: geogebra.gui.i.a.menuSelected[-1]: creating menu items


    File log from C:\Users\Laptop\AppData\Local\Temp\GeoGebraLog_xdouyjabmi.txt:

    Nov 01, 2012 11:52:40 PM

    STDOUT: DEBUG: geogebra.common.i.p.B[-1]: Number of registered views = 1

    * class geogebra3D.b.c

    Nov 01, 2012 11:52:40 PM

    STDOUT: DEBUG: geogebra3D.euclidian3D.S.ag[-1]: create gl renderer

    Nov 01, 2012 11:52:40 PM

    STDOUT: DEBUG: geogebra3D.euclidian3D.opengl.Renderer.<init>[-1]: create 3D component

    Nov 01, 2012 11:52:40 PM

    STDOUT: DEBUG: geogebra3D.euclidian3D.opengl.Renderer.<init>[-1]: add gl event listener

    Nov 01, 2012 11:52:40 PM

    STDOUT: DEBUG: geogebra3D.euclidian3D.opengl.Renderer.<init>[-1]: create animator

    Nov 01, 2012 11:52:40 PM

    STDOUT: DEBUG: geogebra3D.euclidian3D.opengl.Renderer.<init>[-1]: start animator

    Nov 01, 2012 11:52:40 PM

    STDOUT: DEBUG: geogebra.common.i.p.B[-1]: Number of registered views = 2

    * class geogebra3D.b.c

    * class geogebra3D.euclidian3D.S

    Nov 01, 2012 11:52:40 PM

    STDOUT: DEBUG: geogebra.common.b.c.a.a[-1]: Trying to enable SingularWS connection

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.b.c.a.a[-1]: SingularWS supports library grobcovC1

    Nov 01, 2012 11:52:41 PM

    STDOUT: INFO: geogebra.common.j.a.s[-1]: SingularWS is available at http://singularws.idm.jku.at/

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.p.B[-1]: Number of registered views = 3

    * class geogebra3D.b.c

    * class geogebra3D.euclidian3D.S

    * class geogebra3D.d.c.a.b

    Nov 01, 2012 11:52:41 PM

    STDOUT: WARN: geogebra.i.a.s[-1]: Option versionCheckAllow not recognized :

    Nov 01, 2012 11:52:41 PM

    STDOUT: INFO: geogebra.i.x.a[-1]: No system preferences

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.p.B[-1]: Number of registered views = 4

    * class geogebra3D.b.c

    * class geogebra3D.euclidian3D.S

    * class geogebra3D.d.c.a.b

    * class geogebra.common.plugin.b

    Nov 01, 2012 11:52:41 PM

    STDERR: ERROR: geogebra.l.k.b[-1]: Image /gui/menubar/images/en.png not found

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseCFactor

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseCross

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseCSolutions

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseCSolve

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseDot

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseGroebner

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseNIntegral

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseNSolve

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseNSolutions

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseNumeric

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseMixedNumber

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseRationalize

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseSolutions

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseSolve

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseSubstitute

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseToExponential

    Nov 01, 2012 11:52:41 PM

    STDOUT: DEBUG: geogebra.common.i.h.bm.a[-1]: unhandled caseToPoint

    Nov 01, 2012 11:52:42 PM

    STDOUT: DEBUG: geogebra.gui.i.O.b[-1]: update menu

    Nov 01, 2012 11:52:43 PM

    STDOUT: DEBUG: geogebra.plugin.jython.b.c[-1]: Initialising Python interpreter...

    Nov 01, 2012 11:52:43 PM org.python.google.common.base.internal.Finalizer getInheritableThreadLocalsField

    INFO: Couldn't access Thread.inheritableThreadLocals. Reference finalizer threads will inherit thread local values.

    Nov 01, 2012 11:52:47 PM

    STDOUT: DEBUG: geogebra.plugin.jython.b.c[-1]: Done Initialising Python interpreter.

    Nov 01, 2012 11:52:47 PM

    STDOUT: DEBUG: geogebra.gui.a.a$a.a[-1]: Checking version

    Nov 01, 2012 11:52:47 PM

    STDOUT: DEBUG: geogebra.gui.a.a$a.a[-1]: version check needed: no check was done yet

    Nov 01, 2012 11:52:48 PM

    STDOUT: DEBUG: geogebra.gui.a.a$a.a[-1]: current=4009067000 newest=4000041000

    Nov 01, 2012 11:52:49 PM

    STDOUT: DEBUG: geogebra.b.b.g.<init>[-1]: possible missing release()

    Nov 01, 2012 11:52:56 PM

    STDOUT: DEBUG: geogebra.gui.i.a.menuSelected[-1]: Menu opening: class geogebra.gui.i.Y

    Nov 01, 2012 11:52:56 PM

    STDOUT: DEBUG: geogebra.gui.i.a.menuSelected[-1]: creating menu items

    Nov 01, 2012 11:52:56 PM

    STDOUT: DEBUG: geogebra.gui.i.Y.a[-1]: using flag: us.png

    Nov 01, 2012 11:52:56 PM

    STDOUT: DEBUG: geogebra.common.l.n.a[-1]: country from GeoIP: US

    Nov 01, 2012 11:53:26 PM

    STDOUT: DEBUG: geogebra.gui.i.a.menuSelected[-1]: Menu opening: class geogebra.gui.i.ag

    Nov 01, 2012 11:53:26 PM

    STDOUT: DEBUG: geogebra.gui.i.a.menuSelected[-1]: creating menu items

    Nov 01, 2012 11:53:27 PM

    STDOUT: DEBUG: geogebra.gui.i.a.menuSelected[-1]: Menu opening: class geogebra.gui.i.Y

    Nov 01, 2012 11:53:28 PM

    STDOUT: DEBUG: geogebra.gui.i.a.menuSelected[-1]: Menu opening: class geogebra.gui.i.ak

    Nov 01, 2012 11:53:28 PM

    STDOUT: DEBUG: geogebra.gui.i.a.menuSelected[-1]: creating menu items

    Nov 01, 2012 11:53:30 PM

    STDOUT: DEBUG: geogebra3D.d.b.b[-1]: TODO: how to attach 3D view?

    Nov 01, 2012 11:53:30 PM

    STDOUT: DEBUG: geogebra.gui.k.f.a[-1]: invalid toolbar string: null

    Nov 01, 2012 11:53:30 PM

    STDOUT: DEBUG: geogebra3D.euclidian3D.opengl.Renderer.init[-1]: openGL version : 3.0.0 - Build 8.15.10.2626, vbo supported : true

    Nov 01, 2012 11:53:33 PM

    STDOUT: DEBUG: geogebra3D.euclidian3D.opengl.Renderer.init[-1]: openGL version : 3.0.0 - Build 8.15.10.2626, vbo supported : true

    Nov 02, 2012 12:19:27 AM

    STDOUT: DEBUG: geogebra.gui.i.a.menuSelected[-1]: Menu opening: class geogebra.gui.i.R

    Nov 02, 2012 12:19:27 AM

    STDOUT: DEBUG: geogebra.gui.i.a.menuSelected[-1]: creating menu items


    GGB file content:

    <?xml version="1.0" encoding="utf-8"?>

    <geogebra format="5.0" version="4.9.67.0" id="11af4e80-7f1a-4549-8afd-30d7fd4c6079" xsi:noNamespaceSchemaLocation="http://www.geogebra.org/ggb...; xmlns="" xmlns:xsi="http://www.w3.org/2001/XMLS...; >

    <gui>

    <window width="1938" height="1050" />

    <perspectives>

    <perspective id="tmp">

    <panes>

    <pane location="" divider="0.3286893704850361" orientation="1" />

    <pane location="0" divider="0.10319917440660474" orientation="1" />

    </panes>

    <views>

    <view id="4097" visible="false" inframe="true" stylebar="true" location="1,1,1" size="400" window="100,100,700,550" />

    <view id="1" visible="true" inframe="false" stylebar="false" location="3,1" size="432" window="100,100,600,400" />

    <view id="4" toolbar="0 59 || 2020 , 2021 , 2022 , 66 || 2001 , 2003 , 2002 , 2004 , 2005 || 2040 , 2041 , 2042 , 2044 , 2043" visible="false" inframe="false" stylebar="false" location="1,1" size="300" window="100,100,600,400" />

    <view id="2" visible="true" inframe="false" stylebar="false" location="3,3" size="200" window="100,100,250,400" />

    <view id="8" toolbar="1001 | 1002 | 1003 || 1005 | 1004 || 1006 | 1007 | 1010 | 1011 || 1008 1009 || 6" visible="false" inframe="false" stylebar="false" location="1,3" size="300" window="100,100,600,400" />

    <view id="16384" visible="false" inframe="false" stylebar="false" location="1,1" size="500" window="100,100,600,600" />

    <view id="16" visible="false" inframe="false" stylebar="false" location="1" size="150" window="50,50,500,500" />

    <view id="32" visible="false" inframe="false" stylebar="true" location="1" size="150" window="50,50,500,500" />

    <view id="64" visible="false" inframe="true" stylebar="true" location="1" size="150" window="50,50,500,500" />

    <view id="70" visible="false" inframe="true" stylebar="true" location="1" size="150" window="50,50,500,500" />

    <view id="512" visible="true" inframe="false" stylebar="false" location="1" size="1267" window="50,50,500,500" />

    </views>

    <toolbar show="true" items="0 39 59 | 1 501 67 , 5 19 , 72 | 2 15 45 , 18 65 , 7 37 | 4 3 8 9 , 13 44 , 58 , 47 | 16 51 64 , 70 | 10 34 53 11 , 24 20 22 , 21 23 | 55 56 57 , 12 | 36 46 , 38 49 50 , 71 | 30 29 54 32 31 33 | 17 26 62 73 , 14 66 68 | 25 52 60 61 | 40 41 42 , 27 28 35 , 6" />

    <input show="true" cmd="true" top="false" />

    </perspective>

    </perspectives>

    <labelingStyle val="3"/>

    <font size="12"/>

    <graphicsSettings javaLatexFonts="false"/>

    <consProtColumns col0="true" col1="true" col2="false" col3="true" col4="false" col5="true" col6="true" col7="false"/>

    <consProtocol useColors="true" addIcons="false" showOnlyBreakpoints="false"/>

    </gui>

    <euclidianView>

    <size width="432" height="881"/>

    <coordSystem xZero="215.0" yZero="315.0" scale="50.0" yscale="50.00000000000001"/>

    <evSettings axes="true" grid="false" gridIsBold="false" pointCapturing="3" rightAngleStyle="1" checkboxSize="13" gridType="0"/>

    <bgColor r="255" g="255" b="255"/>

    <axesColor r="0" g="0" b="0"/>

    <gridColor r="192" g="192" b="192"/>

    <lineStyle axes="1" grid="10"/>

    <axis id="0" show="true" label="" unitLabel="" tickStyle="1" showNumbers="true"/>

    <axis id="1" show="true" label="" unitLabel="" tickStyle="1" showNumbers="true"/>

    </euclidianView>

    <kernel>

    <continuous val="false"/>

    <usePathAndRegionParameters val="true"/>

    <decimals val="2"/>

    <angleUnit val="degree"/>

    <algebraStyle val="0"/>

    <coordStyle val="0"/>

    <angleFromInvTrig val="false"/>

    </kernel>

    <scripting blocked="false" disabled="false"/>

    <euclidianView3D>

    <coordSystem xZero="0.0" yZero="0.0" zZero="-1.5" scale="50.0" xAngle="44.0" zAngle="-326.0"/>

    <axis id="0" show="true" label="x" unitLabel="" tickStyle="0" showNumbers="true"/>

    <axis id="1" show="true" label="y" unitLabel="" tickStyle="0" showNumbers="true"/>

    <axis id="2" show="true" label="z" unitLabel="" tickStyle="0" showNumbers="true"/>

    <plate show="true"/>

    <grid show="true"/>

    <bgColor r="255" g="255" b="255"/>

    <clipping use="true" show="true" size="1"/>

    <projection type="2"/>

    </euclidianView3D>

    <construction title="" author="" date="">

    <element type="point" label="A">

    <show object="true" label="true"/>

    <objColor r="0" g="0" b="255" alpha="0.0"/>

    <layer val="0"/>

    <labelMode val="0"/>

    <animation step="1" speed="1" type="1" playing="false"/>

    <coords x="-0.58" y="1.04" z="1.0"/>

    <pointSize val="3"/>

    <pointStyle val="0"/>

    </element>

    <element type="point" label="B">

    <show object="true" label="true"/>

    <objColor r="0" g="0" b="255" alpha="0.0"/>

    <layer val="0"/>

    <labelMode val="0"/>

    <animation step="1" speed="1" type="1" playing="false"/>

    <coords x="-1.14" y="-1.56" z="1.0"/>

    <pointSize val="3"/>

    <pointStyle val="0"/>

    </element>

    <element type="point" label="C">

    <show object="true" label="true"/>

    <objColor r="0" g="0" b="255" alpha="0.0"/>

    <layer val="0"/>

    <labelMode val="0"/>

    <animation step="1" speed="1" type="1" playing="false"/>

    <coords x="1.36" y="-1.2" z="1.0"/>

    <pointSize val="3"/>

    <pointStyle val="0"/>

    </element>

    <command name="Polygon">

    <input a0="A" a1="B" a2="C"/>

    <output a0="poly1" a1="c" a2="a" a3="b"/>

    </command>

    <element type="polygon" label="poly1">

    <lineStyle thickness="2" type="0" typeHidden="1"/>

    <show object="true" label="false"/>

    <objColor r="153" g="51" b="0" alpha="0.1"/>

    <layer val="0"/>

    <labelMode val="0"/>

    </element>

    <element type="segment" label="c">

    <show object="true" label="false"/>

    <objColor r="153" g="51" b="0" alpha="0.0"/>

    <layer val="0"/>

    <labelMode val="0"/>

    <coords x="2.6" y="-0.5599999999999999" z="2.0904"/>

    <lineStyle thickness="2" type="0" typeHidden="1"/>

    <outlyingIntersections val="false"/>

    <keepTypeOnTransform val="true"/>

    </element>

    <element type="segment" label="a">

    <show object="true" label="false"/>

    <objColor r="153" g="51" b="0" alpha="0.0"/>

    <layer val="0"/>

    <labelMode val="0"/>

    <coords x="-0.3600000000000001" y="2.5" z="3.4896000000000003"/>

    <lineStyle thickness="2" type="0" typeHidden="1"/>

    <outlyingIntersections val="false"/>

    <keepTypeOnTransform val="true"/>

    </element>

    <element type="segment" label="b">

    <show object="true" label="false"/>

    <objColor r="153" g="51" b="0" alpha="0.0"/>

    <layer val="0"/>

    <labelMode val="0"/>

    <coords x="-2.24" y="-1.94" z="0.7184000000000001"/>

    <lineStyle thickness="2" type="0" typeHidden="1"/>

    <outlyingIntersections val="false"/>

    <keepTypeOnTransform val="true"/>

    </element>

    </construction>

    </geogebra>


    <?xml version="1.0" encoding="utf-8"?>

    <geogebra format="5.0" version="4.9.67.0" xsi:noNamespaceSchemaLocation="http://www.geogebra.org/ggt...; xmlns="" xmlns:xsi="http://www.w3.org/2001/XMLS...; >

    </geogebra>


    LibraryJavaScript:


    Preferences:

    <?xml version="1.0" encoding="utf-8"?>

    <geogebra format="4.0" xsi:noNamespaceSchemaLocation="http://www.geogebra.org/ggb...; xmlns="" xmlns:xsi="http://www.w3.org/2001/XMLS...; >

    <gui>

    <window width="800" height="600" />

    <settings ignoreDocument="false" showTitleBar="true" />

    <labelingStyle val="3"/>

    <mouse reverseWheel="true"/>

    <font size="12"/>

    <menuFont size="-1"/>

    <tooltipSettings language="" timeout=""/>

    <graphicsSettings javaLatexFonts="false"/>

    </gui>

    <euclidianView>

    <size width="640" height="480"/>

    <coordSystem xZero="215.0" yZero="315.0" scale="50.0" yscale="50.0"/>

    <evSettings axes="true" grid="false" gridIsBold="false" pointCapturing="3" rightAngleStyle="2" checkboxSize="13" gridType="0"/>

    <bgColor r="255" g="255" b="255"/>

    <axesColor r="0" g="0" b="0"/>

    <gridColor r="192" g="192" b="192"/>

    <lineStyle axes="1" grid="10"/>

    <axis id="0" show="true" label="" unitLabel="" tickStyle="1" showNumbers="true" axisCross="0.0" positiveAxis="false"/>

    <axis id="1" show="true" label="" unitLabel="" tickStyle="1" showNumbers="true" axisCross="0.0" positiveAxis="false"/>

    </euclidianView>

    <kernel>

    <continuous val="false"/>

    <decimals val="2"/>

    <angleUnit val="degree"/>

    <algebraStyle val="0"/>

    <coordStyle val="0"/>

    <localization digits="false" labels="true"/>

    <angleFromInvTrig val="false"/>

    <casSettings timeout="5" expRoots="true"/>

    </kernel>

    <scripting blocked="false"/>

    </geogebra>

Comments (12)

photo
1

Looks like I am experiencing serious problems with GeoGebra's 3D window on my new laptop, which makes 3D practically unuseable. Any help will be appreciated. A brief description:


1.) Placing points directly in the 3D window does not work - if the mouse cursor moves around the 3D window, the point does not move freely but is bound to the x axis (instead of a cross moving around the xy plane, there is just a "ball" moving along x axis)


2.) If a polygon is placed in the 2D window, that polygon renders correctly in 3D window and, consequently, the point tool seems to work correctly (a cross moving around xy plane). However, the polygon is intouchable - it is impossible to extrude it into a pyramid or prism.


3.) If the projection is changed to anaglyph and the whole 3D view is rotated, zoomed or moved, only the red component rotates/moves/zooms. The cyan component stays fixed at the exact position where the projection was switched to analyph.


I have the same version:


to 1.) not Problem to create free x-y-point. I can move it in every direction. Of cause ... if you click on one axis, you'll get a slider, that can be only moved on this axis. Not a bug, that's a feature ;-)


to 2.) well I got it ... no problem. Did you use the right tool for that action? One possibility might, that the polygon is not really plane, but it should be of cause, if it is drawn in 2D-windows.

Or did you have mixed 2D and 3D points.


to 3.) sorry, but works for me, too. I did as fast as possible moves.


The above problems are the same regardless of a JOGL or classic Windows installation.


Specially for the anaglyph-view there is also the possibility that your grafic-driver causes the problem. Did you tested the other Jogl-Version?


Grüße, Birgit

photo
1

Thanks Brigit for a quick reply. It feels so good to be part of the GeoGebra community with people trying to help each other.


to 1.) not Problem to create free x-y-point. I can move it in every direction. Of cause ... if you click on one axis, you'll get a slider, that can be only moved on this axis. Not a bug, that's a feature ;-)


The point is fixed on the x-axis before I click anywhere. Simply said, it is impossible to place a point anywhere but on the x-axis :( .


to 2.) well I got it ... no problem. Did you use the right tool for that action? One possibility might, that the polygon is not really plane, but it should be of cause, if it is drawn in 2D-windows.

Or did you have mixed 2D and 3D points.


Desperate with not able to place points and draw polygons in the 3D window, I tried to find a work around and first placed a polygon in 2D - that rendered a correct polygon in the xy plane in the 3D window - I was really excited with the progress... but my excitement did not last long as there is nothing I can do with that polygon in 3D :(


to 3.) sorry, but works for me, too. I did as fast as possible moves.


Specially for the anaglyph-view there is also the possibility that your grafic-driver causes the problem. Did you tested the other Jogl-Version?


I tried both Jogls that are on the first page of this forum and I also installed an offline Windows version. Everything works (or does not work) the same way.


Is there a way to check if the graphic driver is the culprit?

Have anyone reported similar problems in the past?

Anyone using GeoGebra 5 with the same graphic card - NVIDIA GeForce GT 650M (2GB)? My other computer has NVIDIA GeForce GT 230 (1GB) and that works just fine.


Tibor

photo
1

Here's a screencast of the problems I mentioned. Please note that the mouse cursor in the screencast (double arrow) is different from what I had on the screen (regular mouse arrow).


http://people.cst.cmich.edu...

photo
1

Hi,


Really really strange : it's the first time I see such bugs... I suppose you've updated your graphic drivers ?


Cheers,

Mathieu

photo
1

Really really strange : it's the first time I see such bugs... I suppose you've updated your graphic drivers ?



Yes, but I did it a while ago so I'll see if there is a new version. I'll let you know if anything changes.

photo
1

No good news. I updated the graphic driver today (clean install) but problems with GeoGebra 3D are still there :(

photo
1

Hi,

just an idea: many laptops have a graphic processor embedded in the mobo, and they always use it, unless you "tell" the system to use the other graphic card, that in your case is the Nvidia GeForce.

This is usually done because dedicated graphic cards are more energy-consuming, so the usual default setting for laptops is to use the embedded chip.

First of all I suggest you to ensure which gpu your system is using. To do so, you need to open the GeForce control panel, then select Desktop in the menu bar, and check the Show GPU activity... option (I'm using an Italian Interface, and I translated the Option name, so in your system it might differ a bit - but I think you understood what I mean).

Now in your taskbar you have an icon showing the nvidia gpu activity. Run GeoGebra, then click on that icon. If the activity is null, this means that your system is using the embedded gpu.

And now the tricky thing: I have no idea on how to say to nvidia to become active when running geogebra v.5!

This is one of the things that I should do, but hadn't enough time to make experiments with. I mean, since my laptop uses the default Intel chip, I usually switch to the nvidia gpu when playing some games which require a better acceleration, and that just works fine, selecting the game from a list of supported games in the nvidia control panel.

I once tried to say to nvidia gpu to activate when using java webstart apps, but she seemed not to be hearing me. :smiley_cat:

Ok, I've spoken too much. Let us know if you've found a solution. I'm now updating the nvidia drivers and hopefully try to study the issue next weekend, since sometimes I have some visualization problems with ggb 5.

Cheers,

S.

photo
1

Ok, fixed :)

Updating the drivers in my case did the trick, because the new drivers had an option the old ones didn't have.

You can easily set ggb 5 to be executed using the nvidia gpu instead of the one embedded in the mobo, just selecting the option "Add Use the graphic gpu to the Context menu", in the Desktop menu of the menubar. (again, I translated what I view in my localized Italian version of the control panel, so you'll probably have a slightly different option, but the long and short of it is that).

From now on, you just need to right click on the ggb v.5 icon, then select the Run using the graphic gpu option, and check nvidia in the appearing list of available gpu(s).

I hope this helped.

In my case it did so (yeeee!)

Cheers,

S.

photo
1

I hope this helped.


Genius! Just right click the GeoGebra icon, choose Run with graphic processor -> High performance NVIDIA processor and all problems are solved!


All the options you described were set as default on my laptop - but I really appreciate your detailed description as it helped me understand what was going on.


You made my day!


Tibor

photo
1

Great !


I think we'll add Mathmum's tip in ggb 3D description ;)


Many thanks !


Cheers,

Mathieu

photo
1

Some more informations: for those how have AMD CPU's (with Radeo Graphic GPUs) and have trouble ... may be have a look the "AMD Catalyst Control Center". There you can change the settings, even for OpenGL.


As I don't have problems, I can't say, if it help in other cases.


Birgit

photo
1

Wow this is incredible. The applet went from totally unusable to buttery-smooth with a single click. (Classic 5.0.507)

Thank you!

© 2021 International GeoGebra Institute