3D not available

Stephen McConnachie shared this question 3 years ago
Answered

Hi, when I open GeoGebra app at https://www.geogebra.org/apps/ then it has no 3D option in the Math Apps pane, and when I open https://www.geogebra.org/3d directly then it reverts to 2D and there is still no 3D option in the Math Apps pane (though the URL remains https://www.geogebra.org/3d). If I'm quick then I see 3D appear in the list and then disappear before I can click it. Help?

Comments (5)

photo
1

Hi, this indicates WebGL is not working in your browser. It may be either disabled in browser settings

(see eg http://techdows.com/2011/05... )


or you graphics card does not support it -- in that case you can try updating the drivers. If it doesn't help please post more information about your setup:

* what's your chrome version?

* what graphics card do you use?


Cheers,

Zbynek

photo
1

Ah, thank you yes you're right my WebGL is not behaving. I've updated all relevant drivers and no change. I'm running a Surface Pro 4, Chrome 56.0.2924.87 (64-bit). I'm not sure about graphics card but dxdiag tells me Display Device Name is Intel HD Graphics 520 - is that the graphics card?

photo
1

Hi, yes, that's the graphics card and it's pretty recent so it should not be the problem. Maybe WebGL is really just disabled in the browser?

http://ccm.net/faq/40585-ho...

http://webglreport.com/?v=1

photo
1

Hmmm nope it says it's enabled. weird

photo
photo
1

Hey


I found a solution to this. It looks like the latest version of Intel is not working properly with GeoGebra. Go to settings - system - display - then find "Display adapter properties". Go to Properties - driver - then press roll back driver version. Voila, GeoGebra 3D now works.


This link shows you how to get into the adapter properties

https://www.intel.com/conte...

© 2020 International GeoGebra Institute