Ärger beim Öffnen von GeoGebra-Dateien

MatheSchmidt shared this question 5 years ago
Answered

Liebes Forum,


nach der Installation des RC GeoGebra 5.02 kann ich meine GeoGebra-Dateien nicht mehr öffnen.

Bei jedem Versuch zeigt mir mein Computer ( Windows 8 ) die Meldung:

Anwendung kann nicht gestartet werden.


Unter Details wird mir mitgeteilt:

[size=85]CouldNotLoadArgumentException[ Angegebene Datei/URL konnte nicht geladen werden: C:\Users\MatheSchmidt\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\61\4fa56afd-4779abf6]

at com.sun.javaws.Main.launchApp(Unknown Source)

at com.sun.javaws.Main.continueInSecureThread(Unknown Source)

at com.sun.javaws.Main.access$000(Unknown Source)

at com.sun.javaws.Main$1.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

[/size]

Natürlich habe ich versucht, in der Systemsteuerung GeoGebra als Standardprogramm festzulegen; das war meine erste Idee. Aber wenn ich die exe-Datei (GeoGebra 4.4/geogebra.exe) als Standard festlege, ändert sich nichts an der Fehlermeldung.


Ich kann schon noch GeoGebra 4.4 starten und dann die Dateien in GeoGebra öffnen, aber das direkte Öffnen der Dateien ohne diesen sehr lästigen Umweg scheitert.

In meiner Not habe ich bereits sämtliche Versionen von GeoGebra in der Systemsteuerung deinstalliert und dann 4.4 und 5.02 neu installiert - ohne Erfolg.


Wer kann helfen?


Vielen Dank im Voraus von

Reinhard

Comments (3)

photo
1

Hallo Herr Schmidt,

hallo Forum,


ich habe das gleiche Problem seit der Installation der 5.0.x Version.


System: WIN7 Home Premium GeoGebra 5.0.8.0-3D (28 September 2014) Java: 1.7.0_40


Ich habe ähnliche Schritte wie Sie unternommen (Neu- bzw. Deinstallation) etc. aber ohne

Erfolg. Natürlich habe ich bei der Installation (als Administrator) "custom" gewählt und

festgelegt, dass GeoGebra mit dem ggb-Filetyp verknüpft werden soll - und zwar für alle

Nutzer des Rechners.


Nach langem Googeln habe ich außerdem folgendes gefunden und dann auch so gemacht:


"Seit Vista wird bei geänderten Zuordnungen in


HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts


ein Eintrag "UserChoice" angelegt. Wenn dieser erst mal da ist, richtet

sich das System nur danach und ignoriert deine Versuche mit anderen Mitteln.

Die alten Methoden kennen kein "UserChoice". Es sollte aber nach Löschen

dieses Eintrages wieder klappen. "


Quelle:

http://answers.microsoft.co...


Außerdem den Registry-Schlüssel von Hand auf Standard geogebra.exe gesetzt.

(VORSICHT!! beim Verändern der Registry )

Das hat aber leider am Problem selbst dann auch nichts geändert.


Allerdings kann man jetzt ggb-Dateien aus dem Internet wieder öffnen, nachdem

zusätzlich im Firefox-Profil die Datei "mimeTypes.rdf" gelöscht wurde, was dazu führt,

dass Firefox bzgl. der auszuwählenden Anwendungen auf Standardwerte zurück-

gesetzt wird. Unter Extras-->Einstellungen-->Anwendungen konnte ich danach

GeoGebra.exe als Standardprogramm zum Öffnen von ggb-Dateien aus dem Internet

wieder auswählen.


Es blieb und bleibt aber das Problem, dass das Öffnen per Doppelklick auf den

Datei-Namen im Datei Explorer nicht funktioniert. Auch wird als Datei-Icon

nicht das Geogebra-Symbol angezeigt.


Das sieht aber anders aus, wenn ich mich als Administrator an meinem Rechner

anmelde. Beim Aufruf des Verzeichnisses mit meinen ggb-Files werden die korrekten

Icons angezeigt und beim Doppelklick auf den Datei-Namen startet Geogebra.

(Kurzes Aufmeckern der Comodo-Firewall ist aber neu).


Das hilft mir aber auch nicht, weil ich natürlich meinen Rechner normalerweise nicht

als Adminstrator betreibe.


Weiß jemand Rat?

Danke Vorab

Andreas

photo
1

Hallo Herr Schmidt,

hallo Forum,


nachdem ich aus anderen Gründen eine Untersuchung der Registry mit dem empfehlenswerten Programm CCleaner vorgenommen hatte, wurde mir dort u.a. ein Problem mit einem ungültigen Datei-Icon für GeoGebra gemeldet.


Nachdem CCleaner dieses Problem behoben hatte, wurden im Explorer die korrekten Icons vor GeoGebra-Dateien wieder angezeigt.


Der gewohnte Doppelklick führte aber zunächst noch zu einer Windows-Fehlermeldung. Allerdings konnte danach dem Filetyp ggb mit den bekannten Windowsmitteln wieder die richtige Standard-Anwendung (also GeoGebra 5) zugeordnet werden.


Nun läuft alles wieder. Das Problem muss übrigens nicht unbedingt durch die Installation von GeoGebra 5 verursacht worden sein.


Ich freue mich, wenn dieser Beitrag jemandem helfen konnte.


Viele Grüße

Andreas

photo
1

Hallo Andreas,


vielen Dank für deinen Tipp. Mein Problem konnte inzwischen auch gelöst werden:

https://forum.geogebra.org/...


Viele Grüße von

Reinhard

© 2020 International GeoGebra Institute