[Résolu] Ubuntu 11.10 oneiric : plantage 3D

jbcools shared this question 10 years ago
Answered

Bonjour,


après mon passage à Ubuntu Oneiric Ocelot, la version GGB5 beta plante si je veux afficher la 3D...

Ca fonctionnait avant, sous Ubuntu 11.04, GGB4 et 4.2 fonctionnent et GGB5 fonctionne sur le même PC sous Windows.


J'ai essayé plusieurs jre, rien n'y fait, je viens de remettre sun java 6 jre que j'avais sous ubuntu 11.04 et d'enlever tout le reste, mais le problème n'est pas résolu.


Le lien http://.../gears.jnlp plante également...


Quelqu'un aurait-il la solution ?


JB

Comments (13)

photo
1

Bonjour,


Problème de pilote de la carte graphique ? As-tu un pilote propriétaire ?


Mathieu

photo
1

La bonne adresse pour tester :

http://jogamp.org/deploymen...

michel

photo
1

Bonjour.

Le problème ne semble pas venir de openjdk :

ggb5 tourne correctement avec openjdk6 sur Arch et sur Fedora.

Et j'ai eu des problèmes d'affichage 3D sous Ubuntu avec Sun Java

6 et 7.

Quant aux pilotes de la carte, j'ai les même versions sous Fedora16

et Ubuntu 11.10, pareil pour Mesa.

Mais je suis en x86_64, c'est peut-être ce qui fait la différence ?

Dernière précision : j'avais pensé à changer jogl, mais le jnlp de ggb5 télécharge son jogl, donc fausse piste...


Phil

photo
1

Re-bonjour


Précisions matériel :

Acer aspire 2930 (en 32 bien sûr) avec Intel GM45,


le driver utilisé semble être le i810 (@mathieu : je ne crois pas qu'il soit propriétaire, en tout cas il est "livré" de base avec Ubuntu et pas mentionné dans la rubrique propriétaire ).


Merci pour tous les conseils. J'avais déjà utilisé le dépôt ppa pour installé sun java 6. J'avoue que j'hésite à réessayer Openjdk parce que ça fonctionnait avec sun java 6 sous 11.04, et que pour l'instant toutes mes tentatives en installant d'autres paquets n'ont pas donné de résultats satisfaisants.


Je ne vois pas quel nettoyage faire en ce qui me concerne pour éviter d'éventuels conflits de drivers, je ne tiens pas à risquer de tuer mon serveur Xorg, ce serait pire que tout.


A vrai dire, il n'y a que la 3D qui ne fonctionne pas, mais le problème, c'est que quand j'ouvre la vue 3D, GGB frise immédiatement et plus rien ne fonctionne avec une forte consommation processeur, ce qui nécessite un kill -9 à chaque fois.


A suivre ...


JB

photo
1

Aarrrf,


un faux espoir : après avoir supprimé le paquet " xserver-xorg-video-i740 ", et un redémarrage,


j'ai réussi à faire tourner sans accroc 1 fois l'applet avec les engrenage, puis je l'ai arrêté, puis j'ai lancé GGB5 et là ça a replanté, et même après un redémarrage de java, les engrenages ne fonctionnent plus ???


C'est louche tout ça...

photo
1

J'ai fait la même chose mais ça ne marche toujours pas...


Il semble en revanche que le Gears.jnlp démarre et fonctionne dès que je fais un changement dans les drivers, quelque soit le changement. Mais il ne fonctionne qu'une seule fois !!!


Je soupçonne donc que quelque chose est mis à jour de manière erronée dans un fichier, mais lequel... le mystère reste entier ;-)


On va creuser...


JB

photo
1

Bonjour, je suis désolé que tu ne trouves pas la bonne configuration.

J'ai vu dans un des messages de mathieu qu'il fallait openGL>2

et je viens de trouver :que ta carte a openGL 2.1 (donc peut être limite)

http://en.wikipedia.org/wik...


Michel

photo
1

Merci Michel pour ta sollicitude. Je vais bien finir par trouver une solution.


Dans la mesure où ça fonctionne sous Windows sur le même PC, la carte ne devrait pas être en cause.


JB

photo
1

Bonsoir,

Pour dire que j'ai des problèmes de mon côté avec Ubuntu 11.10, sur deux ordis différents qui faisaient tourner GeoGebra 5.0 sans problème sous Natty.

Deux cartes graphiques différentes, sur le plus gros ordi (carte graphique Radeon correcte), le repère 3d est visible une seconde puis la fenètre disparaît. Sur le petit eeepc, la fenêtre se fige avant l'apparition du repère, et plus moyen de la fermer... Facheux tout ça, si quelqu'un a une idée... Ou je vais demander de l'aide sur le forum Ubuntu.


Rémi


(je joins le rapport de plantage de java, si quelqu'un sait lire ça...)0223ec44919ef2daab9d4fc0297a497a

photo
1

Bonsoir, tout ce que je peux te dire c'est que je suis là sur Oneiric, avec kernel 3.0.0_12

openjdk et icedtea 6 avec NVIDIA GT520

- J'arrive à lancer et utiliser la 5.0, le seul problème est qu'elle ne se ferme pas, j'ai alors décidé de la lancer par le terminal, et là un Ctrl+C la ferme (cela m'évite killall java)Par contre, l'applet de geogebratube et ceux pour ouvrir les fichiers du forum 4.0 ne fonctionnent pas

- j'ai essayé aussi avec sun.java installé manuellement, et là ça marchait aussi très bien et même mieux car je pouvais fermer la fenêtre et tous les applets marchent

- au delà de la 11.10, ce sont les changements de noyaux qui posent soucis pour adapter les pilotes des cartes graphiques, conseil : ne pas trop se précipiter sur le dernier pilote : j'ai tout planté hier et tout réinstallé (pour la première fois sur Ubuntu)

Patience

photo
1

Bonsoir,


ça y est j'ai essayé. Le résultat est à peu près identique à ce que j'ai eu par le passé :

J'ai créé un script pour automatiser le téléchargement des .jar et .so, selon un exemple vu dans un autre fil :

    #!/bin/bash

    cd /usr/local/GeoGebra/GGB5dnld/

    rm *.jar

    rm *.so

    for i in geogebra geogebra_3d geogebra_algos geogebra_cas geogebra_export geogebra_gui geogebra_javascript geogebra_main geogebra_properties geogebra_usb gluegen-rt-natives-linux-i586 gluegen-rt-natives-solaris-i586 gluegen-rt-natives-windows-i586 gluegen-rt jlatexmath jlm_cyrillic jlm_greek jogl-natives-linux-i586 jogl-natives-solaris-i586 jogl-natives-windows-i586 jogl; do

    wget http://www.geogebra.org/web...

    done

    for i in libjogl libjogl_awt libjogl_cg libgluegen-rt; do

    wget http://www.geogebra.org/web...

    done


Ensuite j'ai essayé les deux méthodes :

1)java -jar /usr/local/GeoGebra/GGB5dnld/geogebra.jar

qui a planté mais c'est peut-être parce que je n'ai pas redémarré ma session et que les variables de chemin


2) java -Djava.library.path=/usr/local/GeoGebra/GGB5dnld/ -jar /usr/local/GeoGebra/GGB5dnld/geogebra.jar

qui a bien démarré mais a fait un joli freeze dès l'ouverture de la fenêtre 3D...


De mon côté ça vient sans doute des drivers de la carte graphique. Ce que je crains c'est qu'en essayant de remettre des drivers de natty, je me retrouve sans serveur X... pour cause d'incompatibilité avec oneiric


Merci en tout cas pour le coup de main,


JB

photo
1

Bonjour, la méthode de Christian est à privilégier sur tout ce qui précède.

Michel

photo
1

Bonjour, je reviens sur ce fil,


pour signaler que :

- sur le pc concerné par cette discussion plus haut : l'installation de ubuntu 12.04 64 bits, a permis une meilleur prise en charge de la carte graphique, ce qui a réglé le problème

- sur mon nouveau PC avec une double carte graphique (intel + Nvidia, système Optimus) , ça marche direct avec ubuntu 12.04 64 bits, mais ça marche encore mieux avec bumblebee (cf. doc sur http://www.ubuntu-fr.org)

- de plus pour ceux qui auraient tout de même des soucis, ou qui souhaitent rester sur 11.10, il est possible que les drivers intel / nvidia du dépôt ppa


https://launchpad.net/~ubun...


règlent le problème


JBC

© 2022 International GeoGebra Institute